Front door speakers not working - Hummer Forums - Enthusiast Forum for Hummer Owners


Sights N Sounds This section is for audio and video clips...discussions about audio and video upgrades can go in our new AV section!

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 05-29-2018, 04:50 PM
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 8
Default Front door speakers not working

I have a 2006 h3 Hummer with the moonso sound system and I am currently replacing all the factory speakers but the front door speakers arenít working. The back door and tweeters work and I even put in new speakers and they donít play any music. This is also the case when the factory speakers are in. They wonít play any music. Anybody with any comments or suggestions on why itís doing this?
Reply With Quote
  #2  
Old 05-30-2018, 07:30 AM
TAINTER's Avatar
Senior Member
 
Join Date: Sep 2008
Location: SE Michigan
Posts: 4,319
Default

Stupid Question. Are the fade settings set to the middle position?
Reply With Quote
  #3  
Old 05-30-2018, 11:44 AM
Senior Member
 
Join Date: May 2008
Location: Shrewsbury, MA
Posts: 136
Default

If the fade in fact, is in the right position, I was having a similar issue in one of our 2006 and it ended up being a loose connection in the large connector between the door and body that has a handle to push down when it is seated properly to lock it in. I could wiggle the connector and get the speakers to work.
Reply With Quote
  #4  
Old 05-30-2018, 01:30 PM
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 8
Default

Quote:
Originally Posted by TAINTER View Post
Stupid Question. Are the fade settings set to the middle position?
yes the fade is in the middle
Reply With Quote
  #5  
Old 05-30-2018, 01:34 PM
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 8
Default

Quote:
Originally Posted by atvspeed4 View Post
If the fade in fact, is in the right position, I was having a similar issue in one of our 2006 and it ended up being a loose connection in the large connector between the door and body that has a handle to push down when it is seated properly to lock it in. I could wiggle the connector and get the speakers to work.
thank you I will try that!
Reply With Quote
  #6  
Old 05-30-2018, 03:09 PM
Junior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 8
Default

Quote:
Originally Posted by atvspeed4 View Post
If the fade in fact, is in the right position, I was having a similar issue in one of our 2006 and it ended up being a loose connection in the large connector between the door and body that has a handle to push down when it is seated properly to lock it in. I could wiggle the connector and get the speakers to work.
where is this connection located at?
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Driver-side Low beam Not Working (electrical issue not bulb) PLEASE HELP TxHummer07 Hummer H3 10 03-22-2015 11:02 AM
Need help Please...Drivers window not working/locks not working JensH2 Hummer H3 11 12-14-2013 02:27 PM
H3 Speakers Not Working, Water Damage AJPhilips24 New Member Area 0 09-11-2011 02:51 PM
What size are front and rear stock door speakers in 07 H3? 2007H3 Audio Visual/Interior Modifications 0 12-11-2007 10:28 PM
H3 door speakers 96TL Audio Visual/Interior Modifications 4 01-29-2007 03:48 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors

All times are GMT -5. The time now is 06:05 AM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.