2007 H3 gremlin search update - Hummer Forums - Enthusiast Forum for Hummer Owners


Hummer H3 For the Hummer driver who wants the rugged look and off road capabilities of the Hummer, but in a smaller size and with a more fuel economy friendly engine.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 09-10-2018, 09:12 PM
Taneo22's Avatar
Junior Member
Thread Starter
 
Join Date: Aug 2018
Posts: 12
Default 2007 H3 gremlin search update

Hello everyone,
So a few weeks ago I purchased my 07 H3 with about 143k. It now has 144656
It has had a few issues I have been diagnosing with the biggest issue being the rough idle.
I've noticed it tends to happen more often when warm and running the ac.
So far I have replaced:
the battery connectors, map sensor, plugs, cleaned throttle body and maf. And replaced the pvc vacume tube.
this has cleared it up some but it still happens periodically. I have ordered a cam position sensor and will post my result when I install it and drive it around some.
If you are having the same issues it's also good to check the wires and connectors to the map and coil packs.
I found some of mine starting to become a bit brittle. None were broken and I used a bit of electrical tape over the connector to help keep the wire movement down.

I am also going to address some rust issues with Blackstar and I will be posting before and after pics of the results.

I hope this helps anyone hunting the same gremlins.
cheers,
Rick
Reply With Quote
  #2  
Old 09-11-2018, 06:07 AM
dafihummer's Avatar
Senior Member
 
Join Date: Jan 2011
Location: Beirut
Posts: 123
Default

I think everyone almost had the rough idle problem . It's pot luck really as it could be one of many
culprits , but mainly throttle body and MAF . I had to change both and do a periodic MAF cleaning
with a proper sensor cleaner . All good so far even with AC on .
Also bad plugs and coils could do the rough idle and hesitation , so it's worth it to change the plugs
and do a coil check . One bad coil and the I5 is dancing
Reply With Quote
  #3  
Old 09-11-2018, 06:41 AM
TAINTER's Avatar
Senior Member
 
Join Date: Sep 2008
Location: SE Michigan
Posts: 4,440
Default

Sometimes the rough idle issue is the intake fasteners (bolts) become loose.
It is a known issue with the I5.
Tighten all of them up and see if that helps.
Reply With Quote
  #4  
Old 09-11-2018, 08:21 AM
Senior Member
 
Join Date: Jul 2013
Location: Virginia
Posts: 193
Default

In my case I had bad compression from a bent valve, you can also check the air filter, if it's really dirty you can get a rough idle. Another thing to try is buying name brand gasoline instead of cheap grocery store gas. Old spark plugs can also cause a really rough idle.
Reply With Quote
  #5  
Old 09-11-2018, 09:36 PM
Taneo22's Avatar
Junior Member
Thread Starter
 
Join Date: Aug 2018
Posts: 12
Default

I will check those. Thank you, it seems to happen when warm with the air on more than with not.
i will check the torq on them thanks again.
oh, yes I agree on the gas. If your couriers I have been running Shell 93 with sea foam last 2 tanks.
It seems to have helped along with the new plugs and sensors.

Cheers
R-

Last edited by Taneo22; 09-11-2018 at 09:43 PM.
Reply With Quote
  #6  
Old 09-13-2018, 04:38 PM
Taneo22's Avatar
Junior Member
Thread Starter
 
Join Date: Aug 2018
Posts: 12
Default New cam position sensor

Replaced the cam position sensor yesterday.
Ran much smoother however once again once it warms up and especially with the air on it still stumble at idle.
New coils will be in next week. I think thatís the last thing I can replace as far as sensors and such go.

Intake bolts seem tight tight cold but Iím thinking about checking them once itís at op temp.
Update again soon.
Reply With Quote
  #7  
Old Yesterday, 09:46 PM
Taneo22's Avatar
Junior Member
Thread Starter
 
Join Date: Aug 2018
Posts: 12
Default

Update:

Coil packs came in today, swapped them out, rechecked my plugs etc.
Has run smoothly with the exception of tonight while waiting at a light I turned on the ac and after a few seconds it stumbled a bit turned the air off it cleared up.
I tried the air again at another light and was fine. So we will see how it runs tomorrow in the heat.
I will update if anything of interest occurs.

Also, for anyone interested in the Blackstar rust treatment, I will start a new thread on it with pic of before and after etc.
Hope to do it in the next few days.

Cheers,
R-
Reply With Quote
  #8  
Old Today, 07:52 AM
dafihummer's Avatar
Senior Member
 
Join Date: Jan 2011
Location: Beirut
Posts: 123
Default

Yes, my rough idle was finally cured with a bad coil replacement .
But the H3 will still hunt for a while till it learns the new parameters .
Or do a code clearing with a scanner .
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
09 H3 electrical gremlin Qwksnke Hummer H3 14 12-23-2016 01:50 PM
H3 Alpha Update: Mileage Update CCMDoc Hummer H3 14 08-07-2007 09:26 AM
had a rough day today "UPDATE" "double update" azz7772 Hummer H3 36 03-16-2007 09:26 PM
Insider Update 2007 H3!!!! SEMO H3 Hummer H3 6 10-16-2006 01:15 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Advertising
Featured Sponsors

All times are GMT -5. The time now is 08:13 AM.


© 2018 MH Sub I, LLC dba Internet Brands
We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.