Go Back   Hummer Forums - Enthusiast Forum for Hummer Owners > Hummer Lineup > Hummer H3
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Hummer Forums - Enthusiast Forum for Hummer Owners.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 01-30-2009, 11:42 PM
Junior Member
 
Join Date: Jan 2009
Posts: 3
Unhappy 06 H3 Passlock Security Light

OK so I've had my H3 for 2 years with no issues other than the annoying wind noise like many have had until just recently. I've seen some threads about H3s not starting but didn't know if anyone has had any corrective success from taking it in to the dealer since most threads are pretty dated.
Here's what happens. Randomly the security light will come on steady while driving. If I turn the car off and back on it sometimes goes away and may or may not come back on. It just bothers me because is comes on randomly. Seems like always when I'm in a rush somewhere or the most inopportune times. And seems to be occuring more and more often. On 2-3 occations I have (like many in other threads) started the car to quickly and not completely thereby triggering the passlock (security light flashes in this case). The manual talks about waiting approx 10 min then restarting. That has worked everytime so far but there is always that thought of what if it doesn't start after 10 mins.
I guess my questions is has anyone seen this in their H3? Has anyone had this issues corrected? How? My biggest concern is getting stuck somewhere and I'm thinking something is up with the car since I haven't changed any habits and this just started happening. Any help would be appreciated.

JV
This ad is not displayed to registered members.
Register your free account today and become a member on Hummerforums!
Reply With Quote
  #2  
Old 01-31-2009, 01:36 AM
Junior Member
 
Join Date: Dec 2008
Location:
Posts: 26
Default

I have seen it once in my 09 H3T. I started it and the pass lock light stayed on, after about 45 sec. I shut it down and waited about 5 sec. restarted and it went away. I called a Hummer service rep and he said that once in awhile if the vehicle is started in hast, the system doesn't recognize the key and the pass lock turns on. He also said he has seen cases when the lock button on the key fob gets bumped prior to or during start up and that can cause it as well.
__________________
2009 H3T Alpha
Reply With Quote
  #3  
Old 02-03-2009, 10:55 PM
Junior Member
 
Join Date: Jan 2009
Posts: 3
Default

Thanks. I've been very deliberate with the key and starting the H3 since I've been having this issue, but it still seems to come on periodically. I think I'll try my wifes key for a while and see if that helps any. My dealer is 2hrs away and it'll take a whole day to get it fixed (if they can fix it).
JV
Reply With Quote
  #4  
Old 02-23-2009, 05:40 PM
Junior Member
 
Join Date: Jan 2007
Posts: 4
Smile Fixed

OK:
So I took my H3 to the dealer last week and he replaced the ignition and reset the security lock. Apparently that all it took. No issues for a week...So far!
__________________
Jimmy V
Reply With Quote
  #5  
Old 02-23-2009, 07:59 PM
Senior Member
 
Join Date: Dec 2008
Posts: 299
Default

I'm happy to hear you got your problem fixed. Annoyances like that are tough to tolerate.
I try to keep these issues in the back of my mind in case it happens to myself or others.
Reply With Quote
  #6  
Old 02-23-2009, 09:34 PM
Junior Member
 
Join Date: Oct 2006
Location:
Posts: 3
Default

Same problem here, it took 3 times to get it fixed with me begging them to change out the passlock module.
__________________
2006 H3 Lux/Adventure Package
2003 Mustang Mach 1 KB Supercharged
2004 Hummer 2
Reply With Quote
  #7  
Old 02-26-2009, 02:25 PM
BrickWurX Mfg.'s Avatar
Senior Member
 
Join Date: Feb 2009
Location: Louisville, KY
Posts: 126
Default

When this problem occurs, unless a remote start is installed that may cause issues, it will always be the passlock cylinder and NOT the key. H3 keys are drone keys only, meaning they have no electronic parts or resistors at all within the casings. The tumbler cylinder itself monitors the rotation of the key and sends out an "all Safe" signal to the control modual. While it is possible to "rush the system", they are designed to be instantaneous and will need replacing per the dealer. The dealer likes to put off anything they can make excuses for, or cannot diagnose per a code reader. The other possibility would be slightly worn key bumps and rizers. each key is vehical specific. They may be worn enough to not trigger the system but still alert the vehical. a new key could fix the problem fast and cheep if your truck is out of warranty. But its mor likely the cylinder is not reading properly to begin with.
Reply With Quote
  #8  
Old 01-28-2014, 07:41 PM
HawaiianH3's Avatar
Senior Member
 
Join Date: Mar 2011
Posts: 160
Default

Hasty starting and more so when its raining does it for me. Might be time to check the sunroof tube.
I found that shooting some graphite lube into the ignition keeps the problem away for awhile. Just sharing this temporary fix as I sit here wasting 10 min before I can get outa here lol
__________________
2006 H3 Base/Chrome/Sunroof , procomp shocks, clear corner led, metal mayhem steering rack mount. 285 Prime Wells.
Reply With Quote
  #9  
Old 01-28-2014, 07:52 PM
hummerz's Avatar
Senior Member
 
Join Date: Jul 2012
Location: C-Town
Posts: 830
Default

Quote:
Originally Posted by HawaiianH3 View Post
Hasty starting and more so when its raining does it for me. Might be time to check the sunroof tube.
I found that shooting some graphite lube into the ignition keeps the problem away for awhile. Just sharing this temporary fix as I sit here wasting 10 min before I can get outa here lol
This is OLD news----> REPLACE THE IGNITION SWITCH, & CLEAN THE PLUG CONNECTOR TO THE SWITCH ONLY.

No need to replace the ignition lock cylinder! No need to use graphite! No need to replace the key! No need to stand on your head while turning the key!

Get to the root of the problem----> Ignition switch replacement & clean/lube the connector.....EASY FIX
To much resistance there=intermittent security lockout!

Worked for me over a year ago, NEVER a problem since.

Last edited by hummerz; 01-28-2014 at 07:57 PM.
Reply With Quote
  #10  
Old 01-29-2014, 09:12 AM
telemike's Avatar
Senior Member
 
Join Date: Oct 2012
Location: Greensboro, NC
Posts: 207
Default

I jsut had PCMofNC turn off the ignition disable when programming my PCM. Now if I get an ignition cylinder failure I am not stuck for 10 minutes.
Reply With Quote
Old 01-29-2014, 09:12 AM
 
 
 
Reply

Tags
06, 09, 2006, flashing, h3, hummer, ignition, light, lock, passlock, problem, problems, reset, security, system


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
All times are GMT -5. The time now is 06:54 PM.

Internet Brands, Inc.