Temperature issue-very frustrated - Hummer Forums - Enthusiast Forum for Hummer Owners


Hummer H3 For the Hummer driver who wants the rugged look and off road capabilities of the Hummer, but in a smaller size and with a more fuel economy friendly engine.

Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 08-12-2017, 02:00 PM
Junior Member
Thread Starter
 
Join Date: Aug 2017
Posts: 1
Question Temperature issue-very frustrated

Hi there, I have a 2007 H3 and for a while now my temperature gauge has been climbing to the 3/4 mark when stopped (stop lights, traffic) and while running in park. It has a new radiator, fan hub and thermostat....any other ideas as to why we are unable to resolve this issue....I'm at my wits end.
Reply With Quote
  #2  
Old 08-12-2017, 04:27 PM
MixManSC's Avatar
Senior Member

 
Join Date: Jan 2017
Location: SC
Posts: 265
Default

That seems reasonably normal to me. When you are not moving the engine is turning a lot slower so the fan in turn is also moving a lot slower and simply cannot move as much air across the radiator. As long as its not going much past 3/4 where it starts getting close to the red zone then I'd think that would be fine.

Nothing you replace is going to prevent it from getting hotter when there is hardly any air moving over the radiator. If it really bothers you the only real option would be to add an auxiliary electric fan and have that setup to kick on at about 200 degrees engine temp. Another benefit to that is your ac will blow a lot colder when sitting too.
Reply With Quote
  #3  
Old 08-12-2017, 08:29 PM
Senior Member

 
Join Date: Apr 2014
Posts: 165
Default

Buy or barrow a Laser Temperature Non-Contact Thermometer Gun and see how accurate your temp gage is.
Reply With Quote
  #4  
Old 08-13-2017, 07:31 PM
Member
 
Join Date: Jan 2016
Posts: 50
Default

I gutted the thermostat and then installed a 185 inline thermostat on the top hose. Also installed and aux pusher fan. Normally hangs around 185-190 on very hot humid days in stop and go traffic with ac on. Also installed wideflow runcool louver on hood to let out engine heat.

Mine is 07 h3 with i5 auto
Reply With Quote
  #5  
Old 08-13-2017, 08:39 PM
Senior Member
 
Join Date: May 2012
Posts: 1,828
Default

my i5 2010 never goes up to midline. checks with obd2 reader.
left shroud off when i did rad change.
Reply With Quote
  #6  
Old 08-14-2017, 09:24 AM
Doc Olds's Avatar
Super Moderator
 
Join Date: Jul 2007
Location: Boat Town USA MI
Posts: 7,674
Default

Quote:
Originally Posted by Shauna Makuch View Post
Hi there, I have a 2007 H3 and for a while now my temperature gauge has been climbing to the 3/4 mark when stopped (stop lights, traffic) and while running in park. It has a new radiator, fan hub and thermostat....any other ideas as to why we are unable to resolve this issue....I'm at my wits end.
3/4 on the dash temp gauge is NORMAL. The new replacement OEM T States are 5 degrees F warmer than the old ones from the factory. You can stop trying to fix what ain't broke.

Hope this puts you back to wit beginning?
Reply With Quote
  #7  
Old 08-14-2017, 09:46 AM
Junior Member
 
Join Date: Apr 2017
Posts: 15
Default

My temp gauge goes up to 3/4 on hot days while sitting in traffic, caught my eye at first but after reading here its normal.
You'll know when it's over heating, the LED Display will say "ENGINE HOT"

My only issue is the a/c does not cool well in the 3/4 temp situation. Any thoughts @Doc Olds
Reply With Quote
  #8  
Old 08-14-2017, 04:46 PM
Member

 
Join Date: May 2015
Location: Texas
Posts: 78
Default

Adding one ounce of PURPLE ICE from ROYAL PURPLE per quart of coolant will drop the temperature measurably! It is also a top shelf corrosion inhibitor and water pump seal lubricant. Another thing to consider is your tune. A lean engine runs hotter and (even within the parameters ) a richer mix will drop the temp.
Reply With Quote
  #9  
Old 08-14-2017, 07:16 PM
RKSmith163's Avatar
Senior Member
 
Join Date: May 2008
Location: Blacksburg, VA
Posts: 759
Default

My 06,08 and 10 all ran about a needles width below half.
Reply With Quote
  #10  
Old 08-15-2017, 09:55 AM
Senior Member
 
Join Date: May 2012
Posts: 1,828
Default

Quote:
Originally Posted by RKSmith163 View Post
My 06,08 and 10 all ran about a needles width below half.

yeah, i forgot my 07m exactly the same , my 10, same.
never over the mid line...
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Strange Idle and Temperature issue. HELP! ARonBoard Hummer H2 4 08-09-2011 09:31 PM
Very yellow, very violent, a horse is injured CHINAHummerGirls Hummer H2 7 08-19-2010 03:36 PM
Very frustrated edna.davis New Member Area 3 05-05-2009 04:10 PM
very cool (very old) h1 vid xzachx2112 Sights N Sounds 3 01-11-2008 06:20 PM
New BCM Needed ?!? SOOO FRUSTRATED 07HummerH3 Hummer H3 4 07-31-2007 10:55 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:26 AM.