Transmission read hot - Hummer Forums - Enthusiast Forum for Hummer Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 04-19-2013, 03:13 PM
Junior Member
Thread Starter
 
Join Date: Jan 2013
Posts: 12
Default Transmission read hot

Drive my 03 H2 around all morning today and on the way to work this afternoon the reading started saying transmission hot? Any suggestions, please!
Reply With Quote
  #2  
Old 04-19-2013, 05:15 PM
Man1nboat's Avatar
Senior Member
 
Join Date: Oct 2012
Location: Denver, CO
Posts: 383
Default

Are you referring to the gage reading hot? Obviously I'm not there so forgive the thoughts here... Is it actually hot i.e. do you smell anything, does it operate ok, etc? Is the fluid burnt i.e. dark, smell funny, etc? If it is operating OK then it could be the gage. If it is a message from the message pane then it could be other items i.e. sensor, wiring, etc... I'd be careful here money and safety-wise... Good luck
Reply With Quote
  #3  
Old 04-19-2013, 05:24 PM
Junior Member
Thread Starter
 
Join Date: Jan 2013
Posts: 12
Default

Reads hot and doesn't want to shift gears. Digital read out says hot and gauge is reading hot. Doesn't to shift out of first it feels like. Revs up real high.
Reply With Quote
  #4  
Old 04-19-2013, 05:52 PM
Senior Member
 
Join Date: Jan 2011
Location: N. Hollywood, CA.
Posts: 605
Default

Time for a visit to the trans. shop! Find a reputable guy in your area and go from there.
Reply With Quote
  #5  
Old 04-19-2013, 07:26 PM
Man1nboat's Avatar
Senior Member
 
Join Date: Oct 2012
Location: Denver, CO
Posts: 383
Default

Man... I would have it towed.
Reply With Quote
  #6  
Old 04-19-2013, 09:27 PM
Senior Member
 
Join Date: Feb 2008
Location: Kansas
Posts: 1,379
Default

Check the fluid level, my 2003 busted the trans cooler in the radiator and it put coolant in the trans, it wiped out the trans and the whole cooling system. $5000 repair.
Reply With Quote
  #7  
Old 04-20-2013, 11:23 AM
Junior Member
Thread Starter
 
Join Date: Jan 2013
Posts: 12
Default

Ok checked the fluid and that seemed fine but it definitely smelt burnt. It was a pinkish color though. Drive around the block this morning, shifts fine until you hit 30mph then revs up and doesn't want to shift? !!
Transmission shop not open till Monday. Any suggestions on what it could be?
Thanks for your replys.
Reply With Quote
  #8  
Old 04-20-2013, 09:39 PM
Senior Member
 
Join Date: Feb 2008
Location: Kansas
Posts: 1,379
Default

It sounds to me like you need your transmission rebuilt. How many miles does it have on it?
Reply With Quote
  #9  
Old 04-20-2013, 10:27 PM
Man1nboat's Avatar
Senior Member
 
Join Date: Oct 2012
Location: Denver, CO
Posts: 383
Default

Yeah... You know, I had a friend that used transmission flush (BG), ran it for a few miles, and had it flushed at Grease Monkey. Maybe worth a shot since you need a tranny fluid change anyway...?
Reply With Quote
  #10  
Old 04-21-2013, 06:51 AM
Junior Member
Thread Starter
 
Join Date: Jan 2013
Posts: 12
Default

I have 82000 miles on it. Taking it first thing Monday morning hopefully won't need a whole new transmission
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2009 H3 transmission noise when cold "Auto Transmission I5 3700 Engine" a7m1 Hummer H3 9 11-20-2014 05:04 PM
Hot Transmission? Shale Hummer H3 5 08-08-2009 11:06 AM
H3 OWNERS in FL AND CA READ THIS!!! importkiller Hummer H3 13 06-14-2006 02:42 AM


Tags
fluid, guage, h2, h3, hot, hummer, level, light, reading, sensors, show, tansmission, tranny, transmission, transmittion

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 08:16 PM.