Hummer Forums - Enthusiast Forum for Hummer Owners

Hummer Forums - Enthusiast Forum for Hummer Owners (https://www.hummerforums.com/forum/)
-   Hummer H2 (https://www.hummerforums.com/forum/hummer-h2-8/)
-   -   No power seat or heater (https://www.hummerforums.com/forum/hummer-h2-8/no-power-seat-heater-36336/)

H2Miami 01-14-2016 08:28 PM

No power seat or heater
 
Just found the driver seat power , driver memory , and heater isnt working
Also the passenger side heater isnt working either

Im guessing it is a relay . Do anyone knows which relay amd where it is located

dwarftosser 01-15-2016 04:50 PM

When mine went out in my 03, it wasn't a relay. I think it was something like memory seat module or drivers seat module (I can't remember specific name, but I can look thru some old files once I get home if you need it).
It's under the drivers seat.

Helga She Is Fine 01-15-2016 11:23 PM

There's a fuse box next to the dead pedal with the fuse that controls all of that in it. I pulled the fuse because after it raines water would leak in and randomly turn on my heated seat, and it would take days to dry out. I can't remember off the top of my head if there is a relay in there.

H2Miami 01-16-2016 10:57 AM


Originally Posted by Helga She Is Fine (Post 332986)
There's a fuse box next to the dead pedal with the fuse that controls all of that in it. I pulled the fuse because after it raines water would leak in and randomly turn on my heated seat, and it would take days to dry out. I can't remember off the top of my head if there is a relay in there.


99% this is the problem . Mine is leaking too . Thats another long story .
It start working again so I guess the water was the issue . Once it os dry then it come back

I got to do something with the water before it seriously damage something

@Dwar hopefully it os not the module . That sound expensive

GroceryGettinH2 01-20-2016 11:00 AM

Just went through this issue.
 
After researching online, I came across 2 possible issues: the fuse listed above (which was not the issue for me) and the connector under the drivers seat (this was my issue)

I would lose both seat heaters, along with no memory or power at all to the drivers seat. There is a connector underneath the drivers seat, on the floor to the left side. Try wiggling this around and retry the seat. If it doesn't work the first time, keep trying.

I did this for a month or 2 before it became almost impossible to get it to work again. Took it to the dealer and part of the connector was burned out. Since they no longer make it, they simply bypassed the connector with the 1 wire in question. This was a few weeks ago and no issues since.

mcioci 01-20-2016 11:53 AM

The only issue I have is with the lumbar not working in drivers seat, everything else works with seat. I tried a new lumbar button (the big round knob) but that did not fix it. Anyone have any ideas?

honda400ex2003 01-20-2016 02:54 PM

/Not to threadjack but anyone care to elaborate where water gets in and makes it act up?

mine does the same crap all the time. it will randomly do it if it is parked odd or something and i never see water anywhere most of the time. on a couple of occasions though, my floor will be soaked under my drivers seat.

assumed that it comes in down the pillar on the drivers side but never could confirm.

thanks,
steve

H2Miami 01-20-2016 03:41 PM

@grocery ... very good point .. mine got the exact same issue and since it start working again last week I didnt worry anymore but yesterday it happens again so Im goimg directly for the switch/plug .. im going to bypass it as well .. thx 4 the info

@honda. Man you touch a injury that is still open ... I've been dealimg.with the water leak for months ..
In my case water is running from the sunroof ... The drain hose must be kind of clogged. It drains but may not be enough for tha amou t of rain we got in Fl
The problem is I cant find the end of the hose . Believe it I tried all ..
Next step is to cut the fck hose and attach a new one . Drill a hole tru the firewall and get it out .

The sunroof got about 1 inch gap between and the truck frame . Very bad design

honda400ex2003 01-20-2016 03:47 PM

that freaking blows... idk where it comes from or goes either. mine has done it since i bought it in 2012. it will be good for 6 months and then poof all of a sudden theres a small pond under my seats haha.

maybe try blowing some air down it and see if that helps it out. i thought mine was coming in by the front driver marker light but it doesnt.

i have had my headliner above the drivers side wet once, the floor wet a few times, my locks malfunction (hasnt happened for a while), heated seats come on and go off by themselves on both sides on occasion but usually just the driver side.

steve

honda400ex2003 01-20-2016 04:02 PM

the other problem, it is the same style of sunroof thats in the rest of the GM vehicles. tahoe, burb, trucks and such never really have much of a problem with them leaking, or ive never really heard of them leaking.

steve


All times are GMT -5. The time now is 05:17 AM.


© 2019 MH Sub I, LLC dba Internet Brands