Go Back   Hummer Forums - Enthusiast Forum for Hummer Owners > Hummer Lineup > Hummer H3
Sign in using an external account
Register Forgot Password?
Search

Welcome to the Hummer Forums - Enthusiast Forum for Hummer Owners.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

Reply
 
 
 
 
LinkBack Thread Tools Search this Thread
  #1  
Old 10-14-2010, 08:20 AM
Junior Member
 
Join Date: Oct 2010
Posts: 4
Default AC wont blow any air =(

Yesterday morning I got in my car and AC worked fine. In the afternoon got in my car and AC wouldnt blow any air at all. Has anyone else ever had this problem?
This ad is not displayed to registered members.
Register your free account today and become a member on Hummerforums!
Reply With Quote
  #2  
Old 10-14-2010, 09:30 AM
Junior Member
 
Join Date: Nov 2008
Posts: 2
Default

Yes, I had the same exact problem. I took it into the dealer and they said there was a wire behind the radio that was slightly pinched. Also check your fuses. This happened to me twice. One day it would work perfectly, then the next it just wouldn't come on. Then it would come on again, and then stop again. I thought it was something major, but in the end was simple fix. Good luck...
Reply With Quote
  #3  
Old 10-14-2010, 10:31 AM
ukpaul's Avatar
Senior Member
 
Join Date: Nov 2008
Location: Morristown, TN
Posts: 129
Default

Sounds the same as a lot of us on here has had.
The wir harness behind the glove box melts on one end and your blower fan stops working.
It's an easy fix and at the same time quite an alarming problem. They should have had a recall on it in my opinion.
The thread is here http://hummerforums.com/forum/showthread.php?t=19208 with pictures.
Good luck !
Reply With Quote
  #4  
Old 10-14-2010, 01:49 PM
Senior Member
 
Join Date: Aug 2010
Posts: 175
Default

Great advice from UKpaul. But definitely check your fuses first.
__________________
I own 06 H2 & 07 H2 + biz hummers. Columbus Hummer Limo rentals Akron Limo Canton Limo Columbus limos Ohio limo rentals
Reply With Quote
  #5  
Old 10-15-2010, 02:05 PM
Junior Member
 
Join Date: Oct 2010
Posts: 1
Default

I'm having the same problem. I checked everything and removed the glove box. When I turn the dial from 3-4 on the level a click comes from the ac compartment. Don't know what it might be or how to get into it. Any help is greatly appreciated.

Thanks,
Reply With Quote
  #6  
Old 10-17-2010, 07:51 AM
Member
 
Join Date: May 2010
Posts: 35
Default

Check the red connector directly behind your glovebox. Its a very common problem and an easy fix. As stated before...there is a thread that covers this.

http://hummerforums.com/forum/showthread.php?t=19208
Reply With Quote
Old 10-17-2010, 07:51 AM
 
 
 
Reply

Tags
ac, air, airconditioner, blow, car, conditioner, conditioning, dont, h2, h3, hummer, radio, removed, turn, wint, wont


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Advertising

Featured Sponsors
Vendor Directory
Our Sponsors
Hummer Off-Road
Bumper Winches at CARiD
All times are GMT -5. The time now is 06:15 PM.

Internet Brands, Inc.



SEO by vBSEO ©2010, Crawlability, Inc.