GFORCE Performance Chip for H3 - Hummer Forums - Enthusiast Forum for Hummer Owners


Reply
 
 
 
Thread Tools Search this Thread
  #1  
Old 10-27-2011, 09:32 AM
Junior Member
Thread Starter
 
Join Date: Oct 2011
Posts: 1
Default GFORCE Performance Chip for H3

I have a 2007 H3, 5 cyl engine. GFORCE claims that their chip on sale for $69 will increase performance across the torque curve by 60HP, increase fuel efficiency by 4-7 mpg with no adverse effects to engine.

Anyone know anything about this or have any experience with it?

Thanks.

Michael
Reply With Quote
  #2  
Old 10-29-2011, 11:06 AM
bflank's Avatar
Senior Member
 
Join Date: Mar 2008
Location:
Posts: 342
Default

Does it also clear up persistent coughs and remove stains? Just betting you are looking at snake oil.
Reply With Quote
  #3  
Old 11-04-2011, 08:58 PM
Member
 
Join Date: Nov 2011
Posts: 30
Default

I would not waste time on this product. If it were capable of creating that much hp it would cost much more and it's most likely a cheap transister from radio shack. Buyer beware on this one.
Reply With Quote
  #4  
Old 11-16-2011, 09:44 PM
RickStang's Avatar
Member
 
Join Date: Nov 2011
Location: Calgary, Alberta, CANADA
Posts: 81
Default

Jesus $69 for 60hp gain!!! I'll take an H3 over a Ferarri anyday!....
I have a Gforce chip, NO noticable gain what so ever. Only thing that is noticable was a "smoother" throttle response.
Reply With Quote
  #5  
Old 11-17-2011, 12:47 AM
TAINTER's Avatar
Senior Member
 
Join Date: Sep 2008
Location: SE Michigan
Posts: 3,734
Default

I also have some great Ocean Front land in Iowa that I just bought from the Government of Bali that I am willing to parcel off ONLY to believers of the "GFORCE claims"!
Reply With Quote
  #6  
Old 11-20-2011, 09:10 PM
Junior Member
 
Join Date: Aug 2011
Posts: 1
Default I have one

I purchased one a few months ago, installed it and did not notice any significant improvements. I removed it and I'm about to send it back. Good Luck. Mine was a Powermax chip from ACDIRECT in Georgia.
Reply With Quote
  #7  
Old 11-21-2011, 04:57 PM
Junior Member
 
Join Date: Nov 2011
Posts: 5
Default

I installed a cold air intake for my 2010 Hummer H3(# KN-77-3065KP) two months ago. Just this morning, the OBD II(On-Board Diagnostic-Second Generation) monitor lit up again. This is the 4th time that I experienced this code. What I did before to eliminate this Engine's Emission Error Code was just to reset the computer box by removing one of the battery's terminal cord.

Any suggestions on what would be the appropriate solution to fix this showing of OBD II code permanently. I am really worried that something might be damaged to my computer box in the future if this will not be properly addressed.

For the meantime, I am still going to unplug again my battery terminal to temporarily fix this problem.
Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
GForce RealDiehl57 Hummer H3 1 07-01-2014 03:37 PM
GForce Performance Chips Det2008SUT Hummer H2 SUT 0 09-09-2012 12:12 AM
Performance chip bcmayo General Hummer Talk 1 11-05-2007 11:37 AM
After-market Performance Chip/Tuner? MPRTKLR Hummer H3 2 03-06-2007 02:06 AM
H3 Performance Chip madmaxmyers Hummer H3 4 07-23-2006 01:17 PM


Tags
2007, chip, chips, cylinder, force, forum, forums, gforce, h3, hummer, increase, performance, powered, review, vbulletin

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -5. The time now is 10:53 PM.